Ga naar inhoud
gizaha

photoplay, please help

Recommended Posts

Hello all! I think i will need help!

I have a photoplay smart 2.1 and it's hdd stopped working.

I replace it with another, now i want to write igo7 (i read that's the latest i can put to this hardware).

First of all, i tried to connect a usb cdrom to photoplay, no luck to boot from cd (old mothermoard).

Then i put the external cdrom and the hdd to a pc, and i had problem again (probably driver-oriented because after creating ramdrive , it said that it could not find cd)

I later tried a sata cd rom in the same machine (with ide mode on bios), no luck again.

The only thing that remains is to try a ide (pata) cdrom.

Question: What's the real problem? What can i do to write disk?

I supposed that photoplay update cds had some limitation, like running only on default hardware but the funny thing is that when i try to boot igo7 iso on virtual machine, it boots and prepares a hdd (virtual), with no problem at all! If anything fails, i will try somehow to write the virtualbox vhd image to the disk.

Secondary, is there is a change replacing the motherboard with better cpu and more ram, in order to put a newer version like AIO12? Of course i have the usb dongle and i will use the same hardware (touch screen, camera, serial connections etc)

Any help will be appreciated! Thanks.

Deel dit bericht


Link naar bericht
Delen op andere sites

Hi, first of all welcome to Retroforum!

Which mainboard do you have?

Most Spirit 2.1 I know are equipped with the 6WEV mainboard. It's quite easy to update, but you have to keep some things in mind.

There are three versions of Photoplay software: PTS-DOS (the IGO-series), NG series (I've never seen them, so I don't know a lot about it) and the Windows XP embedded series (XP series). The spirit 2.1 can run either the latest IGO7 (2007) in DOS-mode or XP 2009.

As the 6WEV is equipped with a Celeron 366 + 64 or 128mb ram the XP version is a nightmare to run. It takes about 5-6 minutes befor you can play and the games really aren't that responsive, there's a slight delay. It may only be a few ms, you do notice.

The IGO version however doesn't have that many options for multiplayer, but I like the games themselves better than the XP version.

Important note: each and every version needs it's own dongles. They will not (!) run without it. The XP version has an USB dongle, the IGO version has a parallel dongle. Each year has it's own dongle, each language has it's own dongle.

So with the parallel IGO version you can not run XP, also the other way around isn't possible.

Notre #2: I've read that the XP version can erase the parallel dongle if it's inserted while you boot or update the XP version. I did not try, but be careful when you run both versions.

Well then upgrading itself. IGO 2007 contains 2 cds and if you have the 6WEV there is a small connector on the front of the system. On the inside there's an IDE cable attached to it. Disconnect it and connect it to an IDE optical drive (you can use cd, dvd, player, burner, it doesn't really matter). Make sure the BIOS is set to boot CD-ROM first. With the 6WEV this should be the case, otherwise you'll need to connect a 5p DIN keyboard (not PS/2) and correct this.

Then it will boot, partition the harddisk, reset the BIOS settings, reboot and install CD #1

After about 10-15 minutes it will ask for CD #2, be quick because if you screw up and wait too long the system will reboot and you'll have to start again.

Put in CD #2 and wat about 5-10 more minutes until it's installed.

Reboot and run.

But first of all make sure you have the correct dongle.

If you have the XP version and XP USB dongle the installation is simple, connect a DVD drive (the update is on a DVD, not on CDs), boot from it, wait.

Good luck!

Deel dit bericht


Link naar bericht
Delen op andere sites

Hello again! Pleasant to meet you.

I have the sprint 2.1 with 6WEV motherboard. I try to update to version IGO7 and i knew almost all of these you said.

I'm not sure what program had the first hard drive (the broken one), but i didn't knew that dongle is for specific version. You mean if it had the IGO3 it will NOT run with IGO7?

The usb dongle is gray, do you know from which version is?

Are you sure about the connector on the front of the system? I didn't find anything, but i will check again today for sure.

Deel dit bericht


Link naar bericht
Delen op andere sites

The USB dongle will *not* run IGO software, you need a parallel dongle for that, it's green for 2007.

When you take out your USB dongle you'll find that it has a language (might be a country code like NL or D or a flag) + year on it. That's the only version you can run with that dongle.

USB dongles are always XP versions, they'll only run the Windows XP embedded versions of the Photoplay software and only the language and year that are on the sticker of the dongle.

So take it out and look at the sticker, that's the version you can run.

About the connector: just take off the cap of the pc that's in your Photoplay and you'll see an IDE cable connected to a small board on the front of the pc. On the other side there's a strange looking connector. That's for the "upgrade box" but when you simply disconnect the IDE cable inside the pc and connect it to a regular IDE DVD drive or burner it will work just fine.

When you lay the pc flat, so the harddrive is on the right, the connector is on the left.

There is a possibility to run IGO7 on it, but you'll need IGO7 software, a IGO7 dongle and maybe some other BIOS settings for the touchscreen to work. I've got 3 versions running on my Spirit 2.1: IGO 2002, IGO 2007 and XP 2006.

Deel dit bericht


Link naar bericht
Delen op andere sites

Then i guess that this system had xp version installed (that explains the gray usb dongle).

I have this smart 2.1

http://www.stockgames.gr/photos/f730d2912f3a747a08d33c5163b3db74.jpg

When you say " just take off the cap of the pc" you mean to take completly out the motherboard case and connect just a screen, cd and the hdd? On some photoplay i opened someday, it was easy to take out the case, in this specific is different and it looks hard.

Im going now to check details

Deel dit bericht


Link naar bericht
Delen op andere sites

Sorry I misread there, I have the Spirit 2.1, the larger version.

I think the Smart can not run IGO versions, because the touchscreen doesn't have DOS support I guess (as I don't own a smart I can't be 100% sure though).

Then just look for a 2nd IDE port on the motherboard, that's where you can connect your DVD player/burner. You might need to add a cable yourself.

Deel dit bericht


Link naar bericht
Delen op andere sites

I spend all my day with no luck.

The previous owner said that the previous falty drive had the 2007 version installed (not specify what kind of "2007")

IGO7 means 2007 or am i wrong?

I found some pages on the internet like this

http://www.arcadoman...lay-Smart-21/en

so i believe that this smart 2.1 can run the igo7. Correct me if im wrong.

*First try: Opened the case, connect an ide cdrom and the hard drive on the same ide cable and connect to motherboard.

Result: No boot, error "bad or missing command interpreter".

Tried only the cdrom without the hdd, the same. Tried some master/slave jumper settings, the same. Tried another ide cdrom drive, same.

*Second try: connect both the cdrom and the hard drive to a pc. All procedure ok, cd boots fine, partitions the hdd and copy files. Then i put the hdd to the photoplay, "cannot find mbr" error.

This applies when i had the hdd ntfs formated before booting from cd. When i format hdd to fat32, it gives error like no having disk at all. When i format the disk to fat (fat16, 4gb partition) it gives cannot find mbr.

I can't think what's wrong. From my point of view, there are these chances:

Bad hdd. I give him some test, some checkdisks, i believe that if it had some errors, it would give some error sometime.

Bad cds. A bit unlikely, looked perfect, burn them yesterday. Again, if there was a problem, it would give error in update procedure.

Some ideas?

ps: on http://update.photoplay.com/photoplay/dvd/old/

what's the difference between the igo7 version, and the "update 2007" version?

update 2007 looks xp version (XPO_OTS04.00.rar) should i give it a try or it would have a dongle problem? I'm still not sure from what year is the usb dongle, is there a change that this machine would had XPO_OTS04.00 version?

aangepast door gizaha

Deel dit bericht


Link naar bericht
Delen op andere sites

Update 2007 is the DVD version of XP, you'll need that one if you have the USB dongle.

You'll need a bigger HDD, I would install a 20GB drive, not a 4GB, it's not enough.

To install the DVD drive should be on the 2nd IDE port, not together with the harddrive.

http://www.medi-gmbh.com/images/Mainboards/maxi/6wev.jpg

If your HDD is on the blue, use the white one for your DVD player.

CD-ROM will not work as the update 2007 image is a DVD.

The USB dongle, has it a sticker on it when you take it out? It should be a small metal dongle with a small sticker on it.

Deel dit bericht


Link naar bericht
Delen op andere sites

HDD drive is 120gb, just the partition the photoplay create is 1.48gb. When i create fat16 partition it didn't allowed me to do bigger than 4gb.

I used CD drive, not dvd drive, since igo7 is 2 700mb isos.

I tried already as you said, cd rom on the white ide and hard disk on the blue, no luck.

I tried cd rom on the white with hdd on it's case and default position, no luck.

The usb dongle just have a sticker that sais "GR" (greek version).

aangepast door gizaha

Deel dit bericht


Link naar bericht
Delen op andere sites

There is a big change that you are right, but the problem wasn't the wrong dongle but the wrong installation.

Anyway, first of all i want to know for sure, for which version is my dongle, in order to try with the correct version.

Since the owner told me something about 2007, tommorow i will try update2007/XPO_OTS04.00.rar

Wish me good luck, any further info about the usb dongle acceptable.

aangepast door gizaha

Deel dit bericht


Link naar bericht
Delen op andere sites

Can you make a picture of your dongle? If you press the grey "Gebruik volledige editor" button on the bottom right you can attach pictures here on the forum itself.

It should be an Aladdin HASP dongle, a few centimeters long, metal casing.

Is there a sticker on the old HDD with a version number on it? Official HDDs come with a "Photoplay - Language - year" sticker.

Deel dit bericht


Link naar bericht
Delen op andere sites

Problem solved.

Forget anything about IGO version. It was needing xpo version, however i could not boot even with xpo.

After countless tests, i discovered that the plastic hdd case was faulty. Or it's ide cable, who knows. When connecting hdd straight to the mobo, it works.

ALSO i had a faulty usb dongle (i didn't knew that usb dongles could die).

I put a 2009 hdd and dongle and it works perfect. I didn't knew that 6wev was compatible with 2009, and it works perfect.

One thing i forgot to ask: In case of hdd failure, can i use other brand hdd, or it boots only with the "Quantum Fireball"? Does anyone tried?

Other things i learned from photoplay, in case that someone needs info:

2007 usb dongle: Yellow sticker

2008 usd dongle: Blue sticker

2009 usb dongle: Green sticker

aangepast door gizaha

Deel dit bericht


Link naar bericht
Delen op andere sites

I'm using an SD-card to boot from. My Spirit 2.1 boots in 20 seconds from power off to usable.

You can use any brand of disk, as long as it's configured to be master and is larger than the minimum required size. I believe IGO has to be 2GB at least, XP needs to be 8GB at least.

For the color I have to look at my 2006 dongle, I'm not sure about USB dongle colors.

Deel dit bericht


Link naar bericht
Delen op andere sites

I just bought this cabinet, but I have a couple of bigger issues with it:

1. I don't have a power cable. What kind of cable does it use and where to get one? I don't want to pay tens of euros for a cord...

2. I have no idea if it works, and if it does, how to start using it 8)7

Obviously I'd love to modify it as far as possible!

Thank you for your answers / help!

Deel dit bericht


Link naar bericht
Delen op andere sites

I just bought this cabinet, but I have a couple of bigger issues with it:

1. I don't have a power cable. What kind of cable does it use and where to get one? I don't want to pay tens of euros for a cord...

2. I have no idea if it works, and if it does, how to start using it 8)7

Obviously I'd love to modify it as far as possible!

Thank you for your answers / help!

Hi and welcome to Retroforum.

Did you buy "this" cabinet like the cabinet from user gizaha, or "the same kind"?

Normally you'd use a regular IEC cable, available about everywhere.

IEC%20to%202%20pin%20euro%20mains%20power%20cable%20BLACK%201.8m.jpg

The other end that goes in the wall socket might look different, according to where you live.

Normally you just turn the thing on, it will boot all by itself, you put money in it (or disable the money option in the bookkeepers menu) and start playing!

Deel dit bericht


Link naar bericht
Delen op andere sites

Hi and welcome to Retroforum.

Did you buy "this" cabinet like the cabinet from user gizaha, or "the same kind"?

Thanks for your fast reply! I ordered the IEC cable, the price was around 3 euros *P*

My friend actually gave this to me when he was moving out. Even he didn't know if it works - because there was no cable. But really soon there will be! This was somekind of a fleemarket find. And no, he didn't tell how much he paid for it.

But then there's the third issue: I broke the key into the lock *) You can call me Mr. Butterfingers... I believe the key had been used for years and since it was made out of some sort of softer metal, it broke inside the lock. I guess I have to drill the hatch open. Luckily it's on the right side, the left side contains the needed connections, if I recall correctly? I hope that this works, I've played these Smarts in restaurants and gas stations. They were quite lame, so I hope there's a place where I can download new games and such. I've seen one which had been modified into a jukebox - that would be an AWESOME feature! I mean, if there's enough space for it. Or maybe there's a way to connect a 1TB hard drive to it??

By the way, can I adjust this into English? It's pretty hard for me to use this forum in your language...

aangepast door GameSeeker

Deel dit bericht


Link naar bericht
Delen op andere sites

Hi, you can switch to English,

On the bottom of the website you'll see: Uiterlijk wijzigen Nederlands Markeer alles als gelezen

Click Nederlands

Click English

If you broke the key you'll need to drill it out. I don't know the Smart that well, it might be the money container. If you don't need it: leave it.

There's no way to get a spare lock with the same key, so you'll need to order a used lock with key if you want it replaced.

I don't see any use for connecting a 1TB drive. The Smart is most likely a Celeron 266 processor with 64mb or 128mb memory. It might run either the DOS or Windows version of Photoplay software. You could update it to 2009, but it's not worth it as it's too slow anyway.

You could replace the whole mainboard, because this mainboard wil fit a Pentium 3 as fastest processor, not much you can do with that, but then you won't be able to run the real Photoplay games on it.

There are some DOS jukebox-tools, but I don't really like them. Also you'll need the hard drives swappable for that. It's a pretty closed system, Photoplay.

Deel dit bericht


Link naar bericht
Delen op andere sites

Thank you so much.

I've been playing the system for a few days now. And I like it :-) But now, every time I put it on, it gives me a warning about the BIOS battery running low: "please remove it" :-( I have no idea how to replace it... And when I do, do I lose all my game achievements and data? And the lock's busted too, I can't acces the mainframe. Well, it's my luck...

Happy New Year 2014!

Deel dit bericht


Link naar bericht
Delen op andere sites

Hi,

You can swap the BIOS battery, the scores/achievements are saved on the hard disk.

You might need to reset the BIOS settings, so take a note of all settings before changing the battery.

It should contain a standard CR2032 battery which should be available for under € 1 (some shops may chagre over € 5 but it's really worth looking around a bit more).

Deel dit bericht


Link naar bericht
Delen op andere sites

I was wondering if someone could help me.

 

I amk trying to connect my 5 SFV photoplay board to my photoplay spirit but I forgot what the configurations of thr IRQ addresses are. Could someone tell me them??

 

Also I have several 6WEV0 boards that when connected don't show any image. Could someone help me troubleshoot them or thell mje the common problems these boards tend to have??

 

Thank you all and best regards

Deel dit bericht


Link naar bericht
Delen op andere sites

from the photoplay spirit 2.1 manual ( with 6wev0 mobo )

 

	funworld i/o adress > 210h
	onboard serial port 1 > 3F8h / IRQ4
	onboard serial port 2 > 2F8h / IRQ3
	onboard serial port 3 > 3E8h / IRQ3
	onboard serial port 4 > 2E8h / IRQ10
	 
	parallel port mode > EPP 1.7
	

Deel dit bericht


Link naar bericht
Delen op andere sites

nice to meet you,,,i have a photo play smart by funworld I.G.O ED. 1 

hard disk show an error about NTLDR is missing...the dongle is green colour but they havent any stick on it to know whick country is.

im from greece..plz help me to make it run..

Deel dit bericht


Link naar bericht
Delen op andere sites
7 minuten geleden, pro8 zei:

nice to meet you,,,i have a photo play smart by funworld I.G.O ED. 1 

hard disk show an error about NTLDR is missing...the dongle is green colour but they havent any stick on it to know whick country is.

im from greece..plz help me to make it run..

Welcome to Retroforum!

 

NTLDR is missing is a sign that Windows has been tried to put on that hard drive.

IGO and the parallel dongle is not for Windows, it's for the PTS-DOS version.

You'll need a different hard drive with the correct software or reinstall the software with the correct cd and the copybox from Photoplay (which is quite hard to find and quite expensive).

 

Best thing to do is find a harddisk with corresponding dongle online, that's the cheapest and safest option.

Deel dit bericht


Link naar bericht
Delen op andere sites

thank you for your soon responce...

will not work?it works but for unknown causes show erros.

i put external cd and i try some edition to install but show me another error "bad or missing command interpreter"

i will upload some pic..pleaze there is a case to work?

Deel dit bericht


Link naar bericht
Delen op andere sites

Can you tell me the total procedure to reinstall the software? Where i connect the cd rom? Is it autoinstall?? Any diffferent setting in BIOS??
There are only two greek versions for smart photoplay and i downloaded them..

Now what?? PLS Help

Deel dit bericht


Link naar bericht
Delen op andere sites
36 minuten geleden, pro8 zei:

Can you tell me the total procedure to reinstall the software? Where i connect the cd rom? Is it autoinstall?? Any diffferent setting in BIOS??
There are only two greek versions for smart photoplay and i downloaded them..

Now what?? PLS Help

You'll need the Photoplay installation box. 

898939748(02).jpg.773472461ed99742446cf61dfe1b8df7.jpg

 

And connect it to your Photoplay computer

 

898939748(03).jpg.a25894e942f77204f1cca3c677ebe416.jpg

You can't use Windows versions.

Best bet is still: buy a second hand hard disk + dongle. From eBay or such, shouldn't cost too much.

Deel dit bericht


Link naar bericht
Delen op andere sites

that's what I'm trying to explain.

-I placed a new hdd 40gb.

-made partition and fat.

-connected IDE CD ROM

-Download the greek version (GR_IGO6)that version has in the old hdd

 but the problem is the same.

what can I do wrong?

Deel dit bericht


Link naar bericht
Delen op andere sites
35 minuten geleden, pro8 zei:

that's what I'm trying to explain.

-I placed a new hdd 40gb.

-made partition and fat.

-connected IDE CD ROM

-Download the greek version (GR_IGO6)that version has in the old hdd

 but the problem is the same.

what can I do wrong?

It only runs on PTS-DOS, you can't just start with any IDE CD ROM.

Also you need the IGO6 dongle if you want to use IGO6.

Deel dit bericht


Link naar bericht
Delen op andere sites
1 hour ago, djkoelkast said:

It only runs on PTS-DOS, you can't just start with any IDE CD ROM.

Also you need the IGO6 dongle if you want to use IGO6.

i have green dongle gr and hdd in fat partition..how way can i repair it?

Deel dit bericht


Link naar bericht
Delen op andere sites

can u plz help to find a hard disk and dongle to fit in my console?

*if you can't write public send me p.m.

thank you very much dear!!!

Deel dit bericht


Link naar bericht
Delen op andere sites

upload some pic to see the details .

i have got a lot of motherboards..can i do some update to run xp series????what i can do to improve..to be more useful?

1.jpg

2.jpg

3.jpg

4.jpg

5.jpg

6.jpg

aangepast door pro8

Deel dit bericht


Link naar bericht
Delen op andere sites

install cd-drive ide

download igo 2006 gr version(2 cd)

boot from cd2..install software and it works!!!

no need Photoplay installation box.

 

*so i was bye and computer photoplay spirit with udb dongle..

aangepast door pro8

Deel dit bericht


Link naar bericht
Delen op andere sites

nice to meet you again..i was bought a usb dongle silver in

yellow colour

DE version

for my spirit 2.1. i

nstall xp07 but when left the last step to play show me a woman to smile and stay there..

some advice?

aangepast door pro8

Deel dit bericht


Link naar bericht
Delen op andere sites

Oi. Desde aprabens pelo fórum. Muito interessante e útil para discussão sobre esses assuntos.

Onde posso encontrar on-line para baixar imagens IGO, para versão multi país. No site do Funworld, existem apenas as versões do AT,( não sei a que país pertencem)m  BE é Belgica, GR é Grécia, IT é Italia, DE é Alemanha,etc, mas PT não tem Eu queria versões para Portugal (PT).  I wanted versions for Portugal (PT).

Cumprimentos para todos, e estou aqui para ajudar, desde que trabalho no ramo da máquina de diversão. Negócio Arcade. Compartilho minha experiência de anos

aangepast door emosPT

Deel dit bericht


Link naar bericht
Delen op andere sites

Hello

 

i have a photoplay barry with update 2000

 

i have a issue. My photoplay is not booting now. It freezes before it should says pts-dos booting...

 

all i did was to take the hard disk from the box and check it at windows to see just at computer management how it was divided the partition has it was a 60gb seagate not original (have only a 1.4 fat16 partion)

 

i put it back to the case and in the photoplay and he detects the hard disk but wont boot.

 

anyone can help me?

 

many thanks

Deel dit bericht


Link naar bericht
Delen op andere sites

Greetings,

 

I have an oldie PhotoPlay Barry 2003 that someone removed all the device cables and reset the CMOS :@

 

Does someone have pictures of the device cable connections on the interior of the PhotoPlay and the BIOS config, please?!

 

Many thanks in advance

Deel dit bericht


Link naar bericht
Delen op andere sites

Maak een account aan of log in om te reageren

Je moet een lid zijn om een reactie te kunnen achterlaten

Account aanmaken

Registreer voor een nieuwe account in onze community. Het is erg gemakkelijk!

Registreer een nieuwe account

Inloggen

Heb je reeds een account? Log hier in.

Nu inloggen

×